Error when doing Quantity Adjustment

We are at 10.1.600.10, and have an issue when adjusting one part for a negative quantity. The BOH shows 2 for a part, in all relevant tables, but when we go to adjust it out, it throws an error, ‘This transaction will result in a negative onhand quantity for the bin.’. I have an open support ticket open for it, but I was hoping someone could point me in the right direction or has seen this before.

We have run the ‘Refresh Part Quantities and Allocations’ for the part number, but it says there are no records when we run it. We also ran the ‘Refresh PartBin QOH fr omPartTran’ with no changes either.

The trace showed the message being generated by the ‘InventoryQtyAdjSvcContract/NegativeInventoryTest’ call. When I run the same call witht he REST services, I get the same result. I am not sure where all the call is checking though.

Does the quantity have a * by it?

Where would I see that?

anywhere a quantity is listed. (quantity adjust, time phase, history)

I don’t know if this is your problem, but if it is, that means the quantity is rounded for some reason. So it looks like it will end up with 0, but you have this tiny negative piece left. To check, try to end up with +1 and see if you still get the error.

Try to change the part class on this part to none (cleared the part class field and saved) and then give it a try adjusting it

1 Like

OK, I understand now. I cannot even adjust it for -1, so I don’t think that’s the issue. Plus I looked in the raw SQL tables, and the number shown in there is 2.000000

Which table is the 2.00 in? There is an overall qty on hand in the part warehouse table, and then a quantity on hand for each bin in the partbin table.

Not sure if it’s related but I had an issue with an adjustment because the qty to be adjusted had more decimals than the UOM allowed. My solution was to go the UOM and set the decimals to max (8), make the adjustment, then change the UOM decimals back

The PartBin has 2, and the PartWhse shows 2, so they are both in agreement

Check for any part allocations on this part & bin in Part Tracker.
Only other time I have seen this error is when there is an allocation or one time there was a pending Material Queue for the Part & Bin.


1 Like

Check the UOM.