First Kinetic 2021.2 build - SSRS Web Portal URL not valid

Building Kinetic - up until now I’ve skipped SSRS because of this issue, but the time has come.

When I deploy my application, it fails with “The SSRS Web Portal URL is not valid”. E10 doesn’t ask, but the URL I got from my SQL server’s Reporting Services Configuration Manager works in my browser.

The URL is http://[myserver]:80/Reports. In the browser, whether entered manually or by clicking on the ling in config manager, it prompts for my domain creds and then redirects to http://[myserver]/Reports/Browse

I must be making a new-guy error, but can’t think what.

1 Like

I found the easiest is to make yourself a local administrator.


Hello @DaveOlender and thanks for that. I am local admin on both the app server and the sql server. I also expanded my permissions in the SSRS portal security. The permissions of all the system profiles check out too.

SSRS is working perfectly for E10 environments on this server pair. But E10 doesn’t ask for web portal URL, only Web Service URL.

I can access, use, upload and download in the web portal URL in a browser.

I can deploy and use Kinetic without SSRS.

I’m local admin with supreme-dictator-for-life permissions - but deploying Kinetic with SSRS enabled is just not working.

I see @ckrusen ran into something similar but fixed it with improved URL strings on E10, but then others (as of this writing) are still stuck.

okay, maybe there is something else I’ve done wrong. I set this up using HttpsBinaryWindowsChannel because it seemed the closest non-TCP selection to what we’re using now (I’m trying to determine how our upgrade will be done still).

I’m getting an error Could not establish trust relationship for the SSL/TLS secure channel with authority [myserver] so I wonder if that error is actually the culprit, stopping SSRS from doing its setup

@SteveFossey Just tossing out ideas. Do you have a cert on the ssrs server? I only use http, so I am not sure why it would need tls?

I also have in my notes that the service account for the apppool should also be a local admin on the ssrs server and I add that account to the sssrs site security as an admin.

From the install guide.
Note If you choose SQL Server Authentication, within SQL you will need to grant the user account specified
in the Application Pool Username field during creation of the Application Server (on the Application Server
Settings tab of the Application Server - Create Site dialog) at least Datareader and Datawriter permissions
to the Reporting database. If possible, it is recommended that Windows Authentication is used with a
dedicated domain user account in the Application Pool Username and that dedicated account has DBO
permissions to the Kinetic transactional and Reporting databases.

It should be /ReportServer at the top and /Reports at the bottom

What does your setup screen look like

@josecgomez I’m just rebuilding it again it, but exactly like that. I’m using a separate VM for SQL but the setup (aside from “Web Portal URL” which doesn’t appear in 10.2) is the same.

I have 4 other 10.2.700 environments running on the same two servers, and if I setup an Kinetic appserver using TCP (but no SSRS) the environment it self runs as happy as a pig in mud.

Edit - I was half-expecting it to just work this time because you asked, but same error:

That’s a good point - we had self-signed everything for some reason, and I found that out recently when opening a WAN port for the first time. So we got a certificate and I don’t know if it was applied everywhere.

Edit - exposing my ignorance here - but the Web Portal URL copied and pasted into a browser opens the portal nad I suppose the “not secure” with no specifics means there’s no certificate?


OK, so now I do have a certificate, although it’s self-signed. I don’t really know what I’m doing though.

Either way, no change - guess this is why we have dev servers ay!

Can you browse to /ReportServer ? What do you get when you go there?

I’ve had this problem using SSRS 2016 but NOT when using SSRS 2017. The architecture documentation only specifically mentions the versions of SQL Server - 2017 or 2019. There is no mention of the SSRS version that should be used - maybe an oversite in the documentation realm?

A server page, after entering my domain creds:

Okay try running the SetupEnvironment with logging turned on and let’s see if we can see what the eror is.

"C:\Program Files (x86)\Common Files\Epicor Software\Application Server Manager Extensions\4.1.200\SetupEnvironment\SetupEnvironmentUI.exe" -Action="Create" -logFile="C:\Temp\log.log" -logLevel="V" -createNewLog="yes"

Then let’s see what exception setup is seeing specifically.

1 Like

@josecgomez will I need a config file? Or does that just open the UI and I take it from there?

Just takes it from there (new deployment)

Ok, that’s (1) cool and (2) embarrassing, because I’ve just been extolling the virtues of CLI Epicor and the extra power it gives you.

I ran it 3 times to try to uncover issues.

  • Using net.Tcp/Windows with SSRS deploying
  • Using https/httpsBinaryWindowsChannel with SSRS
  • Using net.Tcp/Windows without SSRS

I observe that all three have one similar error, "Could not determine if running in Azure", however it doesn’t seem to be fatal

The 2 with SSRS failed after pulling in the Web Portal URL and then throwing, "VerifySsrsRestApiUrl Exception:Error calling GetSystemInfo. ErrorCode: NotFound(404)"

withHttpslog.txt (4.1 KB)
withNetTCP.txt (4.1 KB)
withoutSSRS.txt (10.0 KB)

If I try to browse to http://myDevSQLServer/Reports/GetSystemInfo it prompts for my domain creds and then redirects to the usual home page of the SSRS portal.

Your help is much appreciated - I’d be long since fired without this forum!

Edit - interesting, I didn’t know SSRS had an API (but I guess most things do) but most of the references I can find show the API endpoint being /ReportServer not /Reports. Probably not useful but I tend to think with my keys

Is this box on the domain?

@SteveFossey Can you try with the domain creds of the account running the apppool?

1 Like

Can you visit


What do you get?

Yup, AD not AAD

Pretty much the same thing, except in resolving it pulls up the domain

Good question, I should have thought of that, but as far as I can tell it’s the same: