HandHeld menu shows just numbers

This week for some reason our HandHeld menus only show numbers and not the menu item.

Has anyone seen this before? Any suggestions welcome.


This is a known issue that is being worked on by Development through problem.
PRB0243336 / ERPS-176686

Looks like they have one of their brightest @aidacra on that case! Should be resolved very soon!

Mr. @hkeric.wci: You are right @aidacra is the gold standard.

This started on Monday so we are 5 days into using numbers to navigate the menu’s.

I hope they find a solution soon.

I wonder if you set your language to Blank in User Maintenance as a work around if it will default to Invariant again.


Mr. @hkeric.wci - thank you for the suggestion. I deleted my “Language” field and then restart Epicor (to force it to re-read the profile). The language field stays blank.

I then launched the HandHeld and i get the same numbers instead of menu names.

Thanks again for the suggestion.

@DaveOlender - Did you get a work around? We just upgraded from 10.2.700.6 to 2021.2.8 last night, and see the same result. Yet, during testing, it was fine when we remoted desktop’d in to the handhelds…

@hkeric.wci - My language was blank in my UserID settings.

I searched PRB0243336 / ERPS-176686, but nothing is found (seems that’s the case if it’s not on one of our company’s EpiCare cases), so I created Case CS0002975467 ‘Handheld Menu shows just numbers’.

Epicor got it fixed in the last release a couple of weeks ago. Kinetic 2021.2.9? not sure of the exact release.

Make sure you are using the latest release and it should be fixed.


@DaveOlender - Thanks. Sure enough, fixed on .9 and we’re on .8. I changed my user account language to blank and re-started the Kinetic client, no change. Maybe something is set on the company level and should be left blank there? I couldn’t find anything in Company Config, however. I tried copying the DLL from 10.2.700.6 into the 2021.2.8 client folder, but it errored out when launching the handheld menu.

EpiCare replied that we need to upgrade, but hopefully we can get a work around. We’re unable to update without doing full user acceptance testing, which takes about a month and many hours of everyone’s time. The one time we updated a dot release without full validation, Epicor made some undocumented changes, which broke counter sales for a week, so now we’re not able to take that chance. Once bit, twice shy!