How to update Production quantity? New error

So in the past, if a customer called and asked to increase or decrease the order amount, sales would change it on the sales order, and then call back to the shop, who would pull the paperwork, change the job quantity, and reprint.

After one of the Epicor updates this year, we can no longer change the production quantity, and we have to close the order line and job and make a new one. If we try to change the production quantity we get the following error:

What is the proper process for changing the production quantity?

Hm, we only get this if it was scheduled at some point, but unscheduling and un-releasing doesn’t help…

The error message mentions allocations. Are you allocating this work?

I don’t think so. How would I check?

Any allocations on the JobMtl?

Yeah, I can see the material is reserved, but I can’t find any way to unreserve it.

The Job -> Reserve / Unreserve material window is always empty.

We don’t do reservations/allocations so maybe someone else may know. Sorry Dude.

I found a solution but I don’t like it at all.

  • Change order qty
  • Go to job. Delete the whole job assembly.
  • Add a random material. Any material.
  • Save
  • Delete material
  • Use Get Details to pull back in proper BOM from configuration
  • Save job.

I have no idea why this by passes the error - I particularly find it confusing why the step of adding and removing a random material from the BOM is needed. But if I skip that step I get an error when I use the get details button again.

Can you not “Unallocate and Unreserve” from the Fulfillment workbench?

Also, if you have AMM, it sounds like your “Reserve Inventory on Job Release” setting in site configuration is set. Do you want the stock reserved automatically?

Huh, I had tried that before and no materials were appearing, but I went through the steps again slowly and carefully and I got it to work this time. Maybe unchecking released and Engineered made the job not show up in the fulfillment workbench correctly.

How come I can’t use the Reserve / Unreserve menu item on job entry to do this? Only the non-back flush materials show on this list, whereas they all appear in the fulfillment workbench…

I found that checkbox. Its disabled / locked so we can’t turn it off. Is there any reason to reserve material if we aren’t using MRP? What side effects would turning it off have? (If I can figure out how to get in out of the read only state)

This would only have an effect if you have the Advanced Material Management module. Since it’s greyed out, I would assume you do not.

There are other options on the AMM tab that are not read only though, and even though its read only, its currently checked. Can’t really poke around and see though, I had to get the security manager to look for me.

I’m not aware of anything else that would cause this to be force checked. But it sounds like there is.

Yeah, I tried checking the help file but I couldn’t see anything…

We have our planners use Fulfillment workbench. We are just getting into backflushing, so to this point everything has shown that we expected to see. I would expect backflush items to maybe show, but somehow prevent you from unreserving/unreleasing.