Increase job quantity but subassembly's material does not increase

Kinetic 2021 Public Cloud (but mostly using Classic forms)

We have an Assembly with one SubAssembly set as Pull as Assembly in the method along with three other purchase parts. We increased the job from a quantity of 8 to a quantity of 9. The subassembly and the purchase parts all increased to 9 correctly (assuming a qty of 1:1 with the parent). However the material requirements for the SubAssembly did not. They are all stuck as if we needed 8 SubAssemblies. I can not seem to change it in Job Entry. Very weird. Anyone know what we’re doing wrong?

Thank you!

Depending on your version, I have ran into this bug on a few e10 versions. The solution was to delete the demand link and then add it back. That solved all the calculations.

Andrew Fagan

Thanks @AndrewF - that makes sense except that there has already been some material transactions and therefore Epicor is telling me I can’t delete the demand link. Understandable.

If you split the job (after the job qty was increased), does the new extra job calc the correct qtys of the sub-assy’s components?

The subassembly qty isn’t marked as fixed is it…

Thank you all! I figured it out with hints from all of you. On Job Entry > Job Details > Assemblies > Assembly - under Quantities there was a Pull Qty of 1! So Epicor assumed I wanted to pull 1 sub assembly into the job and so it was only demanding 8 to make the other sub assemblies. I changed the Pull Qty to 0 and voila! It worked. Getting smarter every day.