I've done this before but now forgotten - change the default search

Looking to change the default search for New PO Suggestions to be a BAQ. Everything I’ve tried still comes up with the base screen. The change I made on the search for Parts, months ago, is still working but rather than assisting me in by reminding me how to make the change on PO sugg it’s now just taunting me…

Looks like I can make changes as required on PO Entry but not PO Sugg. Seems like you need to enter quick search criteria to make the “Base Default” checkbox take effect and replace the base search. My POSugg name search seems to have issues when creating criteria:


For searchability:

"There needs to be 1 Binding Token for each ‘%’ token in the Where Clause String.

WhereClause string: Print1099 = true
% Tokens: 0
Binding Token Rows: 1"

It may be related to a search that returns a multi-key index. Like when you search for a line and release from an order, and what is receiving it needs both the OrderLine and OrderRelNum. A BAQ search can only return a single value as the key.

Thanks Calvin. I figure I must be doing something wrong in the New PO Suggestion screen. I’ve updated Purchase Entry without issue. Also, there is a search in place currently on New PO Sugg so I know it’s possible to do but I must be looking in the wrong place.

Just ran a trace of searching for PO Suggestions, and see:

Is your BAQ returning SugPoDtl.SugNum ?

And is that field in the BAQ Search “Like” Columns?

I believe yes to both:


This is what I’m seeing on search for New POSugg:


Hmmm… I’ve got it working. I made a BAQ to return just Suggestions for parts starting with “CB-”

Did you set the Auto Execute option in the Named Search you created?



I do notice that:

  • the Search Criteria Area still shows the “Basic Search” fields
  • the results returned are from the BAQ
  • clicking the Search button, causes the Basic Search to run, and updates the results based on that.

Auto execute set. Looks like this may be an Epicor ticket.

I am trying to remove buyer from the “basic search” fields.

Like hide the search field? It does nothing when the BAQ Search runs.

did you try returning the SysRow instead of the PO number in the Quicksearch? That is how you can do multi-key search on a UD Table and in the Fulfillment workbench. Maybe something similar here?

1 Like

The multiple keys wasn’t the issue. The BAQ only needs to return the single field SugPoDtl.SugNum

For PO Entry all is good and now the behaviour is:

Note how the first screen you see after pressing the binoculars is the new default search with new options (mainly without buyer as no longer required).

Just POSugg giving me trouble

What type of named search is “POHead_ReturnAll” ?

Does this cover:


Also. on the not working POSugg the quick search box is blank:


Yet on working POEntry populated:


I’m sorry … I think I was trying to solve a different problem.

I’m now trying to make a Quick Search, and when I try to add a Criteria, i get that same “Token” error message.

Hi @ckrusen & @timshuwy

Epicor support have reported back this is a bug on POSugg.


Did they provide you with a timeline for correction?

I’m getting the same thing on Vendor.


After doing some additional testing I think I tried too much to overcome the issue that I couldn’t change the base search screen on POSugg which turns out to be a bug. My case references the fact that I can’t update the base search screen so didn’t include the error you attached.