Kinetic ReadOnly (Tracker View) makes custom buttons non clickable

Hi all, Happy New Year!

I have a customized Part Entry screen with some custom buttons. When marking the screen Read Only to use as a tracker, the custom buttons become disabled.

Before I spend to much effort to try to remedy this, I wanted to check and see if anyone has dealt with this. Thanks!

I spent a few minutes trying to replicate that and couldn’t do it. Mine remain clickable. :woman_shrugging:t2:

1 Like

I am on
UX Platform Version:

Are your buttons added as action data on the form?

Mine is:

That could be it. I’ll try and replicate it on an older environment; just for you. :stuck_out_tongue:

Come on. You think I’m basic??! (Yes, they are. :slight_smile: )

Ghost be ghostin’ just fine.


Thanks for checking. Per usual, i find issues unique to myself haha. I will investigate to try to narrow down the issue.

1 Like

I notice your button is on the top row, while mine are on the bottom row.

I doubt location is the issue, but that seems to be a result of App Studio being App Studio.

Deploying it to the menu apparently flips it to the top row. :upside_down_face:

After unchecking and rechecking the secondary row box, it’s still editable.

Any chance you checked the disabled box? lol

Did you create any row rules around them?

Or, just try and circumvent the issue and bind your button, create a copy of their SysReadOnly rule and exclude the button binding. :woman_shrugging:t2:

Sounds like a plan! I have the rule copied. How do I override the system one?

Update: Never mind, it just works. Thanks! You da best!

Update2: Never, never mind. It worked when testing because it wasnt on menu read only. How do I make that copy override the system rule?

It should just work.
I’ll take a look when I get back.

For shits and giggles, can you throw a checkbox somewhere on the page and bind it to TransView.SysReadOnly? See if it lets you uncheck that. If it does, do your buttons become clickable?

Also, try changing the binding on your button to a TransView field if it’s not already.

Confirmed that toggling this toggles the state of my buttons.

1 Like

I see now that I used a different method for my buttons. I actually added them to the main page’s tool bar.

Everything else is as expected.

I noticed in some screens Epicor has had logic that handles read-only on trackers as disable all except these columns. That has included my custom bound buttons. What dataview are your buttons attached to and what kind of row rule is in place for the disable. I ran into this problem in Posted Invoice Update

I am bound to Part.toolPrintSkid for one. Following Hannah’s advice, I copied the system rule for ReadOnly trying to exclude that field. No luck.

Ok, so I will have to go back up and mark Hannah’s answer as the solution. Though I copied the row rule as requested, I just noticed it was disabled by default…groan.

Thanks all for the input and help, especially @hmwillett

I could not get that to work on 2023.1 when I tried it last. I gave up and went back to classic.

Double check that row rule. It wasnt immediately obvious to me that it wasnt enabled because the state of the screen didnt quite jive with my brain (aka the checkbox is for disabled, not enabled). Would be great if they had a row rule to make that red when disabled haha.

Also, I guess you need to make sure your Action view in your rule is the same as the binding view of your control you are trying to affect.