Menu Security Report

Support: “Functions as expected. Closing case…”



Did you actually get that response? I never took the time to create a case.

No. I was being facetious. But since it appears that all users have that issue, it must be a “feature”.

But I am surprised that if the bug is so persistent, that Support isn’t aware of it.

I would bet there is a problem case that has been open for a while.

If so, that sucks that they’d give @Kimberley the run-around, doing things that aren’t the actual solution.

This report runs well on our upgrade “test” production env. (10.2.300.11) Going live this week end, will make sure to test this afterwards…and post the result.


1 Like

This report never worked for us. I suggest making a BAQ and exporting to excel as your report.

1 Like

Have you tried specifying filters?
I have a different version, but it also fails when I run it “wide open” no filters.
After adding a filter, one run was successful at least.
I have run into this issue with other reports, in several versions of Epicor.
Kind of a pain when this comes up… but I can usually break a problem print job up into several runs/filter options.

FYI… the error when running “wide open”… hmmmm?

Microsoft SQL Server Reporting Services 10.50.1600.1
Program Ice.Services.Lib.RunTask raised an unexpected exception with
the following message: RunTask: Client found response content type
of ‘text/html; charset=utf-8’, but expected ‘text/xml’.

Yes I have only selected Active employees which is under 200 so it should run fine. I can run it if I select 1 user.

It ran fine for us in E9 but not in E10

I thought about making a BAQ but always thought getting all the right tables and joins were a nightmare.

1 Like

Yes, I’ve never liked the report so ended up building a few BAQs.

Wonder if you have access to EpicCare? There is a knowledgebase article “BAQ Example of CTE using Menu Hierarchy”.

May be a foundation for adding the security components you need?
Note there are some allow/disallow fields which are tilde separated values, these can be a pain to break out.

1 Like

I pulled that KB but when I try to recreate what they have in there instructions I get an error. Has anyone successfully used this KB?

Attached is a BAQ I used for our security audit during our last upgrade. It gives the full menu structure and the assigned security for each menu item.
PSG-tmsIndentedMenu.baq (39.0 KB)


Thanks this is exactly what I was working on. I don’t understand why i was getting an error. I was trying to change the SubQuery Options and i get this…maybe something is out of sequence.

There should be four subqueries total in the BAQ:

That is what I was just wondering. The instructions from Epicor don’t say you have to have the sub queries first but makes sense… Thanks for your help.

I think CTE queries are more sensitive to the ordering of the subqueries because of how they reference each other. user here.

We have never been successful in running this report with any parameter, open or specific.

We had to create BAQs to get to the data.

If you run it on the server, it sometime works. But it you run it on any workstation, you can bet on it timing out.

1 Like

Hi, i m new in this site, need help to open this BAQ^