MRP is taking a really long time all of a sudden

        On Friday of last week we had someone in our shipping department try to Stage, Ship, Confirm all the shipments for the day while our 6 p.m. MRP was running.  I did not rerun the MRP because it was not necessary.  Then Saturday morning the full regen MRP kicked off and continued to run into the afternoon. 
  • I had to cancel off the MRP and a COSWIP and Auto Job Closing.

  • I did get a full MRP Regen to run in 4 hours later on Saturday.

  • Got the COSWIP to complete.

  • Tried to run a full netchange MRP late Saturday night and it ran into the morning of Sunday and never completed.

  • I came into Metalworks on Sunday afternoon and did a complete shutdown of the server.

  • I then deleted out the cache contained in the C:\Program Data\Epicor folder.

  • Restarted the server.

  • Ran a MRP that went out 1 week and it completed in 20 minutes.

          After all of this I thought I was successful.  However this mornings Full Regen MRP had different ideas.  It only got to Building Parts List Level: 3-0 (which there are 8 of)(which was 7 hours later) and then I had to cancel it so everyone else could get their work done.  Do you have any ideas at all of what may be going wrong?  Our MRP is now broke and I have no clue as to how to fix it.  Please let me your thoughts.

Jill Schoedel

P.S. I have a call into Epicor also but thought I would reach out here as well. Thanks!

In the 8 logs was there a clue or a part it was trying to work on? When ours stopped the end of the logs sometimes had a clue on what it was stuck on.

Does the event viewer on the server have any entries from during the run?

Thanks for the suggestions Greg. The MRP does not just stop on any certain part. I looked for that and was hopeful that is all it was. Unfortunately that was not the case for me.
I looked in the event viewer and there is no errors there either. This whole thing is a mystery.

I was able to get a MRP that went out one week done on Sunday within 20 minutes but not any such luck since.
The Michigan Govenor is shutting us down for three weeks starting tomorrow so I will have lots of time to work on this:>)
thanks again!! Keep the suggestions coming:>)

Just wondering if anyone remembers a conversion program in Epicor 9.05.700C Progress database that you can run to clean up any bad, broken, corrupt MRP files? Please let me know.

Looking for any kind of help I can get. Haven’t been able to run an MRP since last week Friday.

Thanks so much!


Turns out I have a memory leak on our Windows Server 2008 R2 Enterprise 64-bit server. Just wondering if anyone has any suggestions as to the best way to troubleshoot this on a server with our Epicor 9.05.700C Progress database. Any suggestions would be awesome!!!

Thanks so much!!!


Hi Jill,

I had the same issue a few yeas ago on 10.0.7.

As the pressure from the business mounted and with no definitive solution from Epicor being offered , I decided that the only thing to do was to rebuild the app server.

This sorted the issue.

Caveat - I’ve never worked on version 9, so I don’t know if it has the same architecture (i.e. database server and app server), bit if it does, it may be an idea.

Hi Andrew,
Thank you for your suggestion. I am going to uninstall and reinstall my Progress OpenEdge software. I have done this in the past but it has been a long time. I am praying that this will be the magic solution. Really is hard on the stress levels seeing the memory run on high everyday and having to cold restart the server everyday. I am somewhat happy that my plant is shut down right now due to the Corona Virus outbreak. Does give me some breathing room that I normally wouldn’t have had when full production is going.
Wish me luck and if anyone has any tips on how successfully reinstall OpenEdge that they want to pass along that would be great!
I will be drinking a huge cocktail after this if it works:>)

Have an awesome day!

1 Like

Before you do this - what kind of maintenance do you run against your Progress Db? Have you tried cloning this to a Test environment to see if the issue remains? Just wondering if this is something at the database layer causing your issue.

I do have a test server that I refreshed the day before the problem occurred. I will have to do another refresh to see what happens. Thanks for the suggestion!!

I will let you know what happened.

Dan, I did as you suggested and the database does the same thing on my test server. So I guess that points to something at the database level. Any suggestions as to proceed from here? Please let me know.



What do you do for periodic database maintenance? This would be like an index rebuild?

Could you also attach your server logs and MRP logs?

Dan, I haven’t been able to do any kind of index rebuild or other type of maintenance on my database for quite some time due to the size of the database. I need about a week or more to do a Dump and Load.

This all happened when our Shipping guy decided to do his Stage, Ship, Confirm process in the middle of an MRP run. Did not end well. Had to reboot the whole server to clear that one. Afterwards it was taking forever to run MRP’s. They just would not finish. I came in on Sunday and did a complete shut down of the whole server. Then I was able to get a MRP to run but then started or highlighted our Memory issue.

On my Test server there is one appserver that is running higher on Memory than all the others. It points to our Regenerate Configurators process that runs all the time. I am going to try to cancel this and see what happens.

Stay tuned!! :>)

I cancelled off the Regenerate Configurators in my list of Startup tasks on my test server and now things are behaving themselves. Has any else ever had any issues with this process? Any way to fix it? Please let me know.



I have done the same thing to my LIVE server. Waiting until morning before I claim victory. Thank you Dan for the suggestion of cloning this to a Test environment. You have been a big help:>)

Thanks so much!!