Report Data Definitions - Linked Tables don't always work

Hi All

Thanks for your help yesterday.

I am getting a lot closer. In the end I had to edit the regedit to stop the
smart-linking.

I have added the CustCnt table in and linked Customer.PrimBConNum >
CustCnt.ConNum and Invchead.CustNum > CustCnt.ConNum (both left outer join).

I have created formulas to create a pecking order of which details need to be
displayed.

THE PROBLEM is every now and again (maybe 1 in 10 invoices), the group header 3b
(which contains the invcdtl gets duplicated 3 or 4 times in the report so it
lists eg

Line 1 Part
Line 2 Part
Line 3 Par
Line 4 Part
Carriage
Line 1 Part
Line 2 Part
Line 3 Par
Line 4 Part
Carriage
Line 1 Part
Line 2 Part
Line 3 Par
Line 4 Part
Carriage
Line 1 Part
Line 2 Part
Line 3 Par
Line 4 Part
Carriage

This also means the invoice total is multiplied by however many times the lines
have repeated.

Has this happened to any of you?

Do you have any suggestions as to what I can try?

Thanks,


CHRIS




________________________________
From: rec0rder <rec0rder@...>
To: vantage@yahoogroups.com
Sent: Tue, 24 August, 2010 19:05:27
Subject: [Vantage] Re: Report Data Definitions - Linked Tables don't always work

Â
We've had a problem with RDD (v. 9.05.600c) and I've been working with their
support to resolve the issue. Yesterday, I worked with their support person and
he said he could not replicate the issue.


--- In vantage@yahoogroups.com, Joe Rojas <jrojas@...> wrote:
>
> Hi All,
>
>
>
> I wanted to see if others are experiencing this issue.
>
>
>
> I've notice since V8.0 (on E9.04 now) that using the linked tables
> feature in report data definitions (RDD) appears to be a hit or miss.
>
>
>
> In my latest example, I was trying to add the tracking number from a
> shipment to the AR invoice. I went to a duplicate of ARForm RDD that I
> made, went to Linked Tables and included Packnum -> TrackingNumber. I
> then I printed an invoice for a shipment that I know had a tracking
> number and the tracking number field was blank.
>
> I ultimately had to add ShipHead to the RDD, establish a relationship,
> and now the tracking number is pulled over.
>
>
>
> Anyone else experience this before? I guess I surprised to see the
> problem still exists in 9.04, which could mean that I've been doing
> something wrong all these years. :)
>
>
>
>
>
>
>
>
>
>
> Joe Rojas | Director of Information Technology | Mats Inc
> dir: 781-573-0291 | cell: 781-408-1264 | fax: 781-341-5694
> jrojas@... | www.matsinc.com Ask us about our clean, green and beautiful
>matting and flooring
>
>
> This message is intended only for the individual named. If you are not the
>named addressee you should not disseminate, distribute or copy this e-mail.
>Please notify the sender immediately by e-mail if you have received this e-mail
>by mistake. Please note that any views or opinions presented in this email are
>solely those of the author and do not necessarily represent those of the
>company.
>
>
> [Non-text portions of this message have been removed]
>







[Non-text portions of this message have been removed]
Hi All,



I wanted to see if others are experiencing this issue.



I've notice since V8.0 (on E9.04 now) that using the linked tables
feature in report data definitions (RDD) appears to be a hit or miss.



In my latest example, I was trying to add the tracking number from a
shipment to the AR invoice. I went to a duplicate of ARForm RDD that I
made, went to Linked Tables and included Packnum -> TrackingNumber. I
then I printed an invoice for a shipment that I know had a tracking
number and the tracking number field was blank.

I ultimately had to add ShipHead to the RDD, establish a relationship,
and now the tracking number is pulled over.



Anyone else experience this before? I guess I surprised to see the
problem still exists in 9.04, which could mean that I've been doing
something wrong all these years. :)










Joe Rojas | Director of Information Technology | Mats Inc
dir: 781-573-0291 | cell: 781-408-1264 | fax: 781-341-5694
jrojas@... | www.matsinc.com Ask us about our clean, green and beautiful matting and flooring


This message is intended only for the individual named. If you are not the named addressee you should not disseminate, distribute or copy this e-mail. Please notify the sender immediately by e-mail if you have received this e-mail by mistake. Please note that any views or opinions presented in this email are solely those of the author and do not necessarily represent those of the company.


[Non-text portions of this message have been removed]
Joe;
Yes, this has been a constant thing throught the different releases. We have the issue with SalesCat in the Part Master. Even though you can "Browse" the data in Crystal with a linked table, it will not display it. I had this issue on the xfileref table on 8.03 when it first came out, and they finally got it fixed, but I had to do a lot of leg work to get them to do it, and it took 5 months. I think it takes a long time for these things because there are probably three people in the world that want it or know about it.

Just have to keep finding ways around it I guess. Bummed to hear it is still the same in 9.0x.

Regards,
GLH

--- In vantage@yahoogroups.com, Joe Rojas <jrojas@...> wrote:
>
> Hi All,
>
>
>
> I wanted to see if others are experiencing this issue.
>
>
>
> I've notice since V8.0 (on E9.04 now) that using the linked tables
> feature in report data definitions (RDD) appears to be a hit or miss.
>
>
>
> In my latest example, I was trying to add the tracking number from a
> shipment to the AR invoice. I went to a duplicate of ARForm RDD that I
> made, went to Linked Tables and included Packnum -> TrackingNumber. I
> then I printed an invoice for a shipment that I know had a tracking
> number and the tracking number field was blank.
>
> I ultimately had to add ShipHead to the RDD, establish a relationship,
> and now the tracking number is pulled over.
>
>
>
> Anyone else experience this before? I guess I surprised to see the
> problem still exists in 9.04, which could mean that I've been doing
> something wrong all these years. :)
>
>
>
>
>
>
>
>
>
>
> Joe Rojas | Director of Information Technology | Mats Inc
> dir: 781-573-0291 | cell: 781-408-1264 | fax: 781-341-5694
> jrojas@... | www.matsinc.com Ask us about our clean, green and beautiful matting and flooring
>
>
> This message is intended only for the individual named. If you are not the named addressee you should not disseminate, distribute or copy this e-mail. Please notify the sender immediately by e-mail if you have received this e-mail by mistake. Please note that any views or opinions presented in this email are solely those of the author and do not necessarily represent those of the company.
>
>
> [Non-text portions of this message have been removed]
>
I am having a similar issue with a UDF I created in the Part table. I am needing to place it within a subreport of my Traveler. I know the data is there as I just recently entered it myself.

--- In vantage@yahoogroups.com, "pcivantage" <pcivantage@...> wrote:
>
> Joe;
> Yes, this has been a constant thing throught the different releases. We have the issue with SalesCat in the Part Master. Even though you can "Browse" the data in Crystal with a linked table, it will not display it. I had this issue on the xfileref table on 8.03 when it first came out, and they finally got it fixed, but I had to do a lot of leg work to get them to do it, and it took 5 months. I think it takes a long time for these things because there are probably three people in the world that want it or know about it.
>
> Just have to keep finding ways around it I guess. Bummed to hear it is still the same in 9.0x.
>
> Regards,
> GLH
>
> --- In vantage@yahoogroups.com, Joe Rojas <jrojas@> wrote:
> >
> > Hi All,
> >
> >
> >
> > I wanted to see if others are experiencing this issue.
> >
> >
> >
> > I've notice since V8.0 (on E9.04 now) that using the linked tables
> > feature in report data definitions (RDD) appears to be a hit or miss.
> >
> >
> >
> > In my latest example, I was trying to add the tracking number from a
> > shipment to the AR invoice. I went to a duplicate of ARForm RDD that I
> > made, went to Linked Tables and included Packnum -> TrackingNumber. I
> > then I printed an invoice for a shipment that I know had a tracking
> > number and the tracking number field was blank.
> >
> > I ultimately had to add ShipHead to the RDD, establish a relationship,
> > and now the tracking number is pulled over.
> >
> >
> >
> > Anyone else experience this before? I guess I surprised to see the
> > problem still exists in 9.04, which could mean that I've been doing
> > something wrong all these years. :)
> >
> >
> >
> >
> >
> >
> >
> >
> >
> >
> > Joe Rojas | Director of Information Technology | Mats Inc
> > dir: 781-573-0291 | cell: 781-408-1264 | fax: 781-341-5694
> > jrojas@ | www.matsinc.com Ask us about our clean, green and beautiful matting and flooring
> >
> >
> > This message is intended only for the individual named. If you are not the named addressee you should not disseminate, distribute or copy this e-mail. Please notify the sender immediately by e-mail if you have received this e-mail by mistake. Please note that any views or opinions presented in this email are solely those of the author and do not necessarily represent those of the company.
> >
> >
> > [Non-text portions of this message have been removed]
> >
>
This is a known issue with 904, 905 and I have been told it is fixed in
906.



From: vantage@yahoogroups.com [mailto:vantage@yahoogroups.com] On Behalf
Of Mike
Sent: Monday, August 23, 2010 10:53 AM
To: vantage@yahoogroups.com
Subject: [Vantage] Re: Report Data Definitions - Linked Tables don't
always work





I am having a similar issue with a UDF I created in the Part table. I am
needing to place it within a subreport of my Traveler. I know the data
is there as I just recently entered it myself.

--- In vantage@yahoogroups.com <mailto:vantage%40yahoogroups.com> ,
"pcivantage" <pcivantage@...> wrote:
>
> Joe;
> Yes, this has been a constant thing throught the different releases.
We have the issue with SalesCat in the Part Master. Even though you can
"Browse" the data in Crystal with a linked table, it will not display
it. I had this issue on the xfileref table on 8.03 when it first came
out, and they finally got it fixed, but I had to do a lot of leg work to
get them to do it, and it took 5 months. I think it takes a long time
for these things because there are probably three people in the world
that want it or know about it.
>
> Just have to keep finding ways around it I guess. Bummed to hear it is
still the same in 9.0x.
>
> Regards,
> GLH
>
> --- In vantage@yahoogroups.com <mailto:vantage%40yahoogroups.com> ,
Joe Rojas <jrojas@> wrote:
> >
> > Hi All,
> >
> >
> >
> > I wanted to see if others are experiencing this issue.
> >
> >
> >
> > I've notice since V8.0 (on E9.04 now) that using the linked tables
> > feature in report data definitions (RDD) appears to be a hit or
miss.
> >
> >
> >
> > In my latest example, I was trying to add the tracking number from a
> > shipment to the AR invoice. I went to a duplicate of ARForm RDD that
I
> > made, went to Linked Tables and included Packnum -> TrackingNumber.
I
> > then I printed an invoice for a shipment that I know had a tracking
> > number and the tracking number field was blank.
> >
> > I ultimately had to add ShipHead to the RDD, establish a
relationship,
> > and now the tracking number is pulled over.
> >
> >
> >
> > Anyone else experience this before? I guess I surprised to see the
> > problem still exists in 9.04, which could mean that I've been doing
> > something wrong all these years. :)
> >
> >
> >
> >
> >
> >
> >
> >
> >
> >
> > Joe Rojas | Director of Information Technology | Mats Inc
> > dir: 781-573-0291 | cell: 781-408-1264 | fax: 781-341-5694
> > jrojas@ | www.matsinc.com Ask us about our clean, green and
beautiful matting and flooring
> >
> >
> > This message is intended only for the individual named. If you are
not the named addressee you should not disseminate, distribute or copy
this e-mail. Please notify the sender immediately by e-mail if you have
received this e-mail by mistake. Please note that any views or opinions
presented in this email are solely those of the author and do not
necessarily represent those of the company.
> >
> >
> > [Non-text portions of this message have been removed]
> >
>





[Non-text portions of this message have been removed]
We are on 8.03.409a. Do you know of any work arounds?

--- In vantage@yahoogroups.com, "Mike Anstey" <manstey@...> wrote:
>
> This is a known issue with 904, 905 and I have been told it is fixed in
> 906.
>
>
>
> From: vantage@yahoogroups.com [mailto:vantage@yahoogroups.com] On Behalf
> Of Mike
> Sent: Monday, August 23, 2010 10:53 AM
> To: vantage@yahoogroups.com
> Subject: [Vantage] Re: Report Data Definitions - Linked Tables don't
> always work
>
>
>
>
>
> I am having a similar issue with a UDF I created in the Part table. I am
> needing to place it within a subreport of my Traveler. I know the data
> is there as I just recently entered it myself.
>
> --- In vantage@yahoogroups.com <mailto:vantage%40yahoogroups.com> ,
> "pcivantage" <pcivantage@> wrote:
> >
> > Joe;
> > Yes, this has been a constant thing throught the different releases.
> We have the issue with SalesCat in the Part Master. Even though you can
> "Browse" the data in Crystal with a linked table, it will not display
> it. I had this issue on the xfileref table on 8.03 when it first came
> out, and they finally got it fixed, but I had to do a lot of leg work to
> get them to do it, and it took 5 months. I think it takes a long time
> for these things because there are probably three people in the world
> that want it or know about it.
> >
> > Just have to keep finding ways around it I guess. Bummed to hear it is
> still the same in 9.0x.
> >
> > Regards,
> > GLH
> >
> > --- In vantage@yahoogroups.com <mailto:vantage%40yahoogroups.com> ,
> Joe Rojas <jrojas@> wrote:
> > >
> > > Hi All,
> > >
> > >
> > >
> > > I wanted to see if others are experiencing this issue.
> > >
> > >
> > >
> > > I've notice since V8.0 (on E9.04 now) that using the linked tables
> > > feature in report data definitions (RDD) appears to be a hit or
> miss.
> > >
> > >
> > >
> > > In my latest example, I was trying to add the tracking number from a
> > > shipment to the AR invoice. I went to a duplicate of ARForm RDD that
> I
> > > made, went to Linked Tables and included Packnum -> TrackingNumber.
> I
> > > then I printed an invoice for a shipment that I know had a tracking
> > > number and the tracking number field was blank.
> > >
> > > I ultimately had to add ShipHead to the RDD, establish a
> relationship,
> > > and now the tracking number is pulled over.
> > >
> > >
> > >
> > > Anyone else experience this before? I guess I surprised to see the
> > > problem still exists in 9.04, which could mean that I've been doing
> > > something wrong all these years. :)
> > >
> > >
> > >
> > >
> > >
> > >
> > >
> > >
> > >
> > >
> > > Joe Rojas | Director of Information Technology | Mats Inc
> > > dir: 781-573-0291 | cell: 781-408-1264 | fax: 781-341-5694
> > > jrojas@ | www.matsinc.com Ask us about our clean, green and
> beautiful matting and flooring
> > >
> > >
> > > This message is intended only for the individual named. If you are
> not the named addressee you should not disseminate, distribute or copy
> this e-mail. Please notify the sender immediately by e-mail if you have
> received this e-mail by mistake. Please note that any views or opinions
> presented in this email are solely those of the author and do not
> necessarily represent those of the company.
> > >
> > >
> > > [Non-text portions of this message have been removed]
> > >
> >
>
>
>
>
>
> [Non-text portions of this message have been removed]
>
Epicor 9.04.506

Hello, a little help with a BPM
I am simply trying to update all of the QuoteDtl.CheckBox05 checkboxes
when QuoteHed.Checkbox01 is checked. The BPM saves fine, but the action
doesn't work in Quote Entry.

PreProcessing Update

Action:

for each ttQuoteHed where (ttQuoteHed.RowMod = 'U' or ttQuoteHed.RowMod =
'A'), each ttQuoteDtl where ttQuoteDtl.Company = ttQuoteHed.Company and
ttQuoteDtl.QuoteNum = ttQuoteHed.QuoteNum and ttQuoteHed.CheckBox01 = True
exclusive-lock.
Run lib\UpdateTableBuffer.p(input BUFFER ttQuoteDtl:HANDLE,
'CheckBox05',"YES").
End.

Thanks in advance
We've had a problem with RDD (v. 9.05.600c) and I've been working with their support to resolve the issue. Yesterday, I worked with their support person and he said he could not replicate the issue.

--- In vantage@yahoogroups.com, Joe Rojas <jrojas@...> wrote:
>
> Hi All,
>
>
>
> I wanted to see if others are experiencing this issue.
>
>
>
> I've notice since V8.0 (on E9.04 now) that using the linked tables
> feature in report data definitions (RDD) appears to be a hit or miss.
>
>
>
> In my latest example, I was trying to add the tracking number from a
> shipment to the AR invoice. I went to a duplicate of ARForm RDD that I
> made, went to Linked Tables and included Packnum -> TrackingNumber. I
> then I printed an invoice for a shipment that I know had a tracking
> number and the tracking number field was blank.
>
> I ultimately had to add ShipHead to the RDD, establish a relationship,
> and now the tracking number is pulled over.
>
>
>
> Anyone else experience this before? I guess I surprised to see the
> problem still exists in 9.04, which could mean that I've been doing
> something wrong all these years. :)
>
>
>
>
>
>
>
>
>
>
> Joe Rojas | Director of Information Technology | Mats Inc
> dir: 781-573-0291 | cell: 781-408-1264 | fax: 781-341-5694
> jrojas@... | www.matsinc.com Ask us about our clean, green and beautiful matting and flooring
>
>
> This message is intended only for the individual named. If you are not the named addressee you should not disseminate, distribute or copy this e-mail. Please notify the sender immediately by e-mail if you have received this e-mail by mistake. Please note that any views or opinions presented in this email are solely those of the author and do not necessarily represent those of the company.
>
>
> [Non-text portions of this message have been removed]
>