Reports - Appearing on my machine not theirs!


Bit of a strange one. I don’t understand what has changed or if I have changed something?

Every time someone print previews a report. It will appear in my screen not theirs! This is happening in our Pilot instance and now our production instance. We are SaaS

I have removed the edge printing agent from my machine and removed it from our local server. I have been modifying reports but I cannot understand how this would affect it popping up on my machine not theirs? The only way they can preview the report is to click the ‘bell’ icon and click on the report.

Please can someone explain to me.

My notification panel… I didn’t print any of these LOL



What do you have selected in company maintenance for workstation method?

Blank mate…

Trying changing it to machine name + user id?
I have no idea if it will help you, just, filling that in has solved some strange problems for us so throwing it out there.

1 Like

We tested that on our pilot system and still the same.

Requires a app pool recycle and being SaaS and multiple company, multi-timezone. Challenging.

Maybe its a new bug

1 Like

PR created. :smiley:

I’m clueless… Never experienced this before.

1 Like

What patch are you on?

We are experiencing this too. We were told it was a bug.

1 Like


1 Like

that’s great

Are government or SOX compliant companies able to leverage cloud? Is it even possible with a bug like this or some of the others like the homepage security oversight?

I think this one will fix it temporarily. Need to trace it out in yours to see what the where clauses say just to be sure.

1 Like

Thanks Kevin, I have yet to fuss around with it, but I want to.

We made some quick fixes in that other thread, but @jgiese.wci looked into it a little further than I did, and I think his is the best approach, although I’m not sure if it’s complete.

A little tracing will answer that though.

1 Like

Yeah that’s what I am saying, haven’t been able to do a little tracing and probably won’t till after go live.

I know what was provided was pretty much the majority of what needed to be traced/developed, just a tiny bit to go if someone would like to use it.

@aarong Did you have any luck fixing this?

1 Like

No, I didn’t… Awaiting for epicor to get a solution together…

1 Like

we tried the work station method and set it as follows, it appears to have stopped the issue for us.

1 Like

I was about to say, this is somethign that has been covered by @aidacra

Like this has happened as far back as Epicor 10.

Let’s talk about SSP (server-side printing) - Experts’ Corner - Epicor User Help Forum (

This is the post in that thread linked above that talks about what @dadams just mentioned, the “workstation method”