User Cannot Copy to Excel grayed out

Hi All,

I am having an issue where just one of my users is unable to ‘Copy to Excel’ even though Excel and Epicor are both installed on the machine. This is greyed out no matter what screen he is in.

Any thoughts on what the issue may be?

If he has Windows 10 OS, it does not allow it. However, there is a reg edit fix to allow it.

I just did this on my new PC.

** Randall Lunsford**


Excel Machinery Ltd

An Employee Owned Company

Direct: 806-350-1531

Toll Free: 800-858-4002

Skype -

Have you seen our brand new website?


P Please join me in making a difference. Think before you print.

This is due to how we are checking to determine if a local install of Excel was on a workstation + MS changing where they put their registry keys with their latest version of Office. This is tied to Epicor ERP SCR ERPS-93134.

Workaround for the time being. This will insert a registry key in the location where the ERP clients are looking to determine if Excel is really installed.

  • Please copy the attached .txt file to a machine that has this issue.
    excel.application.txt (560 Bytes)
  • Rename so that it has a .reg extension.
  • Double-click to import.
  • Close out of the Epicor client and log back in.
  • Please try to test to verify that option is now available and works as expected. If so, repeat on your other machines with this issue.

PUBLIC SERVICE ANNOUNCEMENT: never blindly trust people on the Internet when they offer you registry fixes to an issue. Open it up, make sure it makes sense to you, and if it does (and only then) implement ideally in a way that you can restore your environment to a point before this was implemented if something goes wrong.


Thank you Nathan!

Thank you so much! this worked for me! struggled with it for a while :frowning:


Hi Nathan,

I know you addressed this a while back but we have a few users that can not copy to excel since moving to a Win10 Laptop. I tried the fix you posted and it worked on the administrator login (could not install on the user profile due to permissions) but not on the users login. I then made the user a local admin and that still did not work. Any thoughts? TIA

Check the permissions on the keys created and see if making any changes makes any difference.

1 Like

The registry fix just worked for me. Figured I’d let everyone know this is still a working solution. Thanks Nathan!


The registry fix is no longer a working solution with Office 365. Tried it many, many times.
The only fix right now seems to delete the Windows User’s profile where Copy Excel does not work and recreate it. This is not a good solution since recreating a user’s profile takes a lot of time. Epicor needs to provide us with a reasonable solution or at least let us know where to look for the issue

@nyamoga9 you might just need to modify the registry fix

Try this one: excel.application.2020.txt (560 Bytes)

This has been fixed in 10.2.300, 10.2.400 apparently and if you used the old registry fix then of course you would be pointing it to a non-existing Excel hence the Gray out. I would either use the new fix or avoid using the fix all together in order not to corrupt the new settings with old values. (assuming you have it running on your GPO or something)

I have no issues because I never used the old reg fix either.

You might want to check your regedit see if you are on .16 maybe there is a .17 even which I dont see in mine.


Nice @hasokeric

I finally found the ‘proper’ way to fix this finally. (the registry fixes above did not work for me.) I use Office 365, but the article still worked :slight_smile:

Quick Repair worked.

1 Like