BAQ List for Dropdown in UBAQ Works for 2/3 fields only

I have a BAQ that effectively combines two lists of salespeople (one tied to Work Force and another tied to a User Code field we use). I have some UD fields on the Task table that denote additional responsibilities (instead of only being able to assign it to one person). We have 3 fields: primary, secondary, tertiary. I use the same BAQ to populate the Advanced Column Configuration for those three updateable fields in my UBAQ. Amazingly, it only works for 2 of the 3. They are all setup identical. And to make it worse, it seems to switch between which 2 it works for… What in tarnation? Is there some sort of rule that you can only use the same BAQ populated dropdown twice in a single BAQ? See below screen shot. All 3 fields circled in red are setup the same way.

How does it not work? Like is the third combo just empty? Does it switch which field doesn’t return any data? What makes it switch? On refresh? Does your BAQ have any parameters? I have no idea what could cause this issue, but these answers will help get closer!

Third combo drops an empty list (like a list pops down when you click the arrow but there are no items in it).

I can’t say what makes it switch. As I was trying to see if it was related to the UBAQ, the dashboard, etc. I would pop open the test assembly in the dashboard, vs. using the menu path to the dashboard, and when I would randomly select records to test it appeared to be inconsistent with which was the field that would not give me a list. Oddly, it used to work just fine. So I’m not sure what I did… the BAQ does not have any parameters.

I am turning the corner on taking a completely different approach to what I’m trying to accomplish to see if that helps. At the end of the day, I still need 3 updateable fields all linked to a BAQ for the list. One dumb thing I haven’t tried it to just make 3 separate BAQs that are identical and have each column reference a different one.

I have to ask.

Are you Sure you set up your drop down lists identically?

Does the first dropdown work correctly? 100% of the time?

Yes. I must’ve checked 10 times now to make sure my eyes weren’t deceiving me.

No. Sometimes it doesn’t.

Shot in the dark, remove them all and add them back.

I tried that one already. Currently, I am in the process of copying them to three separate identical BAQs, haha. Ugh.

three separate identical BAQs seems to do the trick. Annoying, but I’m happy to have it working.

1 Like

david cross wtf GIF by Cheezburger

So weird!

1 Like