DMT won't let me process Quantity Adjust due to parentheticals in the columns it is lookingfor


I’m trying to use DMT to do a number of quantity adjustments related to my end of year physical inventory. I do not want to process this whole list by hand but my year end processes need to finish ASAP.

I am in DT and forced to use the DMT client assigned by the update routine. We are current on this machine, windows 10.

I make a template and fill it in. The template tells me the following are required when I validate it. All columns are valid. I hit Process


So I add these two optional columns. I can validate, but get the same error again when processing.

What is odd is if I rename them to this I get this error here when I load the file, (error at vaildate)


But I can actually process the file now! But then I get this error


1 Like

What version of DMT are you running?

And what does the first row of your import file look like?

I have attached a generated template the header row should look like what is in the file.qtyAdjustTemplate_4.0.44-10.2.400.xlsx (7.4 KB)

If your company config is configured to use Inventory Adjustment Reasons (Modules/Materials/Inventory/General), you will need a reason valid reason code, so make sure it is populated with one that is. So check either Material Management/Inventory Management/Setup, Production Management/Job Management/Setup, Production Management/Quality Assurance/Setup or Sales Management/Customer Relationship Management/Setup to confirm that the reason code you have is valid.

If any of your part are serial tracked then you would also need to populate a serial number (although I have never had a need to use that personally).

I’m surprised the header validated with the (Company Preference) in the column header.

Hope that helps.

If your company settings require Reason Codes, you need to supply them.

To determine if they are required, do a manual qty adj, and see if it balks about needing a reason code.

Also, that DMT column will need to use the actual ID code.


I will try yours. I do this every year at this time, never run into this. It’s bizarre.

If you are still running into issues try an earlier version of the DMT.

This is no longer possible in Dedicated Tenancy. We have our DMT forced into the client and can only use the current version that matches the server version.

I dropped it to one row, this should be valid.


This is expected and should give an error. But it is the only way to make it process. That is not expected.

This is what is unexpected. It’s like it is strictly checking for the name in parenthesis. Why it would do this… i don’t know. A software bug?

I would be definitely logging this with Epicor support.

I have just notified the team on this one clearly an issue.

Hi Aaron,

I tested it on my Virtual Environment and it seems mine is working fine, please take a look.
Attached the a copy of the DMT file.
test.csv (124 Bytes)

Hi Mauricio,

You said you’ve tested on your virtual Environment. If, and I’m not aware of dedicated tenancy infrastructure, you’re using a different DMT client can you compare versions?

Mine is on premise. DMT for 10.2.400.
Yours pretty sure is the latest release correct? could you please confirm version so I can try and run some tests?

Also, and this is a shot in the dark, I have seen some postings where DMT is particular on the case of characters for certain fields. In your last screen short, of where the import works, the plant is different to the other screenshots.

For the plant ID that shouldn’t a problem at all, is an open field so you should be fine. My main concern will be about the last 2 columns name.

Oops, getting the folks are posting / creating the post confused. Anywho, here are two posts related to DMT and Case Sensitivity:

For the sake of a quick test on a one line CSV file it will be a quick test to rule out.

I posted this. My screenshots are for a 1 line DMT. This is in Dedicated Tenancy and I can’t download a different DMT than the one pushed by the autoupdate client to my machine.

It really looks like someone who programmed it set two columns as required which can’t be part of the file. I think they wanted an informational error and instead made “SerialNo (SN Tracked Parts)” required instead of leaving it optional, and made “ReasonCode (Customer Preference)” a required field, neither of which are field names - so you could never process. Looks to me to be a straight up programming and QA issue.

Case CS0001858931 was logged off of the VM I left and they identified this as a known issue and sent me a ZIP of a different DMT program to try. I am doing that now.

//edit:Problem code PRB0218343.

The ZIP provided in my ticket does work with the standard CSV file, just like it has in previous years.

We need a known issues page for DMT. The program has had these “quirks” for too long that we are all working around. This is taking years off my life.

1 Like

If you can’t wait for a fixed version of DMT, you could get all your qtys updated by doing a pseudo Physical inventory.

Just generate tickets for for the parts you need to update, then in the count entry enter the qty you want to end up with. NOT THE ADJ QTY!!!

A Phys Inv just creates a bunch of Qty Adj’s. But instead of users enter the adj amount, they enter the actual amount, and Phys Inv process calculates the difference.

When you first enable a Phys Inv, it takes a snap shot of the QOH’s for the date selected. This Qty along with the qty in count entry, are used to determine the adj qty.


  1. Start a phys inv
  2. Query the cycle count tables to get the expected qty’s
  3. in excel, add the Adj Qty’s that you were trying to DMT, to the expected qtys to get the “Counted Qty’s”
  4. Past the “Counted Qtys” (Exp Qty + Adj Qty) into count entry.
  5. Review and post

Your column headings should be ReasonCode and SerialNo not ReasonCode (Company Preference) and SerialNo (SN Tracked Parts)

1 Like

Yes Matt is correct. We do qty adjustment dmts all the time and the column names should be ReasonCode & SerialNo