E9.04.507A DMT Inventory Transfer - "There are no warehouses left to be assigned"

I am trying to transfer about 500 parts from an existing warehouse to a newly created warehouse.

I ran a DMT to create the Part Plant Warehouse records for each of the parts in the list without error.

Now when I am trying to perform the actual transfer I am getting an error “There are no warehouses left to be assigned.”

I have a ticket open with Epicor but they have not yet provided a solution.

According to them, the error indicates one of the following
-The part doesn’t have a valid Warehouse for the same site.
-The part is not registered where you are doing the transfer.

Both of which are not the case.
I can perform the transaction in the system without error.

I am using a .csv template with the following headers in this order.
Company,Plant,FromWarehouseCode,ToWarehouseCode,FromBinNum,ToBinNum,PartNum,TransferQty.

Any thought would be helpful.

Thanks
Clive

This may be a long shot, but arrange your required data columns in the same order as the way the DMT suggests. The DMT lists the columns like this: Company, Plant, PartNum, TransferQty, FromWarehouseCode, FromBinNum, ToWarehouseCode, ToBinNum.

I have seen data not get processed if it is not in the order DMT suggests.

Rick,

Thanks for the input. Interestingly enough my DMT suggests the columns in the order I listed above.
I will try the order you have provided, can’t hurt.

Clive

No joy. I get the same result.

For the heck of it I tried to do a transfer from one bin location to another within the same warehouse and get the same error “There are no warehouses left to be assigned.”

Epicor support is sending this on to the Development team.

So what I will do instead is to run a DMT to adjust out the quantities from warehouse and then adjust then into the new warehouse.

Thanks

When trying to move quantity, which specific DMT Import template are you using? Sounds almost like you’re trying to do it against the PartPlant Import, not the Inventory Transfer one.

I have been using the Inventory Transfer Import.

@CG2 I know this is an old post but I ran across it when looking for an answer to the same question. I think it’s actually (in my case) simply concerning the time it takes to update the database. I am moving about 200 parts and this has happened before:

  • create bin locations by DMT
  • set primary bins by DMT
  • use SQL to generate the DMT to move parts from current bin to newly created and named primary bin
  • transfer fails with “No warehouse left to assign” on all items
  • wait 2 or 3 minutes and try again, in defiance of Einstein’s definition of insanity
  • transfer happily works with no errors

I came back here to write it down partly in case it helps but mostly because I’ll hopefully remember it better next time for having written it :roll_eyes:

aaaaaaand… a year later, I’m going to confirm my diagnosis. Just tried to move a bunch of parts and about 30% of them failed with “No warehouse left to assign”.

I searched the forum, found this thread, and looked at 2019 me staring at me with the answer… felt dumb, obviously that’s not it…

But yup. I ran the ErrorsReprocess CSV and the leftover 30% happily uploaded with no error. Oh Epicor.

2 Likes

Well here I am, I guess I mark just waiting and trying it again as a solution. I tried 3 times in row no luck, very next try it took. What a weird solution

1 Like

Just be sure to use the automatically generated “errors reprocess” file so you don’t accidentally duplicate the ones that worked.

1 Like

I have the same problem now, I haven’t been able to make it work!

This didn’t work for me. I am having the same issue

want to post your templates just in case someone here has an idea?

Created Templates from DMT, so they were good. I managed to make it work by using a different Epicor account (doesn’t make sense but that what did it for me)
Previously, I was using the Manager account)

oh, that’s not surprising actually. Manager account doesn’t automatically have access to all security groups, access scopes, etc.

I have some same DMT with Manager account many, many times, in the same system with same rights and it always worked before :frowning:

another thing I do is split my DMT in two when there is a persistent failure. Often I find one row is jacking up and the error takes long enough to time out that all subsequent rows fail. Sometimes splitting it lets half complete, then I split the remainder, etc.