Requisition is not generating PO Suggestions


Hello everybody,

I want to know how I can generate PO Suggestion manually from Requisition entry when these were not generated automatically?. The case is the following:

The users are creating their Requisition by using “Requisition Entry”. Once requisition was created and approved by his respective manager, the system generates the PO Suggestion to see it by using New PO Suggestion screen. However, this process not always is working well. For example, for a requisition with more than one lines the system is generating just some suggestions, but this issue is not happening always.

Curiously, one solution (not ideal) is reset dispatcher from Requisition Entry and now PO Suggestion are generated.

As developer, I am thinking to create a BPM on Update method that can differ between POSugDtl and ReqDetail and insert manually the lines that were not created automatically by the system. It is just an idea, so crazy?

Can you give me an idea or there is a better solution for this issue?
best regards,
Juan Pablo

Have tried using Generate suggestion, this process will look for approved Purchase requsition.


Note that requisition PO suggestions, if deleted, will not be recreated when Generate Suggestions is run. I believe you can get them to show up again by resetting Requisition dispatch and re-approving.

Hi @prash172, yes i did it, but without results.

Hi @zwilli526,

The solution that you said works, but it is not ideal, we are looking for solution where isn’t necessary resetting requistion dispatch and re-appoving. Do you know why this could be happening?

Try checking the part master setup.
generate po suggestion not selected.


all parts that were not generated like suggestions have Generated PO Suggestions checked.

Can you check the “Due Date” on the requisition? Then Check the “Cutoff Date” and "Process Date on Generate Suggestions.

Ran into some issues recently where this was the culprit. If you leave the dates blank on Generate Suggestions, it defaults to System current date.

Also, confirm that the items are not showing up as change suggestions.

Hi @Fernando,

I tried your solution but I does not show the PO Suggestion.

The following image shows the Requisition Ready to be purchased, in theory it should show in New PO Suggestion.

After run the Generate Suggestion like you described, I couldn’t see the Requisition.

Does it need to be approved? I noticed the status said pending on your screenshot.

No, this requisition already was approved and it is pending to purchase.

Could you check the user who is opening the “New PO Suggestion” has the access to the required buyer.
Users who should generate PO must be an authorized user in the buyer maintenance.
And if you have a setup of partclass should be handled buy respective buyer, then cross the check the requisition partclass may be user is not an authorized buyer.

1 Like

If you did not already find a solution, I just ran across this same issue (or similar).

Turned out the underlying issue was the buyer was not able to see the PO suggestions because they were not an authorized buyer for the buyer on the PO suggestions.

The requisitions where the PO suggestions were “missing” were approved and sent to Purchasing by the CFO. The parts on the requisitions were parts-on-the-fly and their part classes did not have a default buyer assigned, so the PO suggestions created from the requisitions defaulted to the requisition approver (the CFO). The main buyer in Purchasing is not an authorized buyer for the CFO for financial control reasons so the PO suggestions where the CFO was listed as buyer were not visible to the main buyer.

Our solution is to set all part classes to have a default buyer, in this case the main buyer in Purchasing.

(thanks to @timshuwy for a post in Jan 2019 which gave the clue!)