Epicor 10.2 Upgrade - Scheduled MRP & PO tasks immediately CANCEL

Upgraded to 10.2 last night.
Noticed that scheduled tasks for MRP & PO’s immediately cancel.
This is also the case when ran manually.
Actual error was ‘Invalid System Agent username or password.’
Reviewed the System Agent and the Task Agent Service user account.
Task Agent Service is configured with no epicor user, but System Agent was set to an old Epicor user account that no longer exists.
Environment is SSO, and per the Field help we should not set either.
Set System Agent to blank for user, password, etc and restarted task agent.
Still PO Sugg immediately cancels.
Opened a case with Epicor Support this morning, no response yet.


We ran into the same issue today.

Check the user account you are using for your System Agent. What are you using? Make sure they are set up and you can long in as that user.

That was our issue. We were missing the Print User.

1 Like

This one is tricky since we use SSO Windows binding. When connected to the app server on Windows binding, User Account Security Maintenance doesn’t reset password as expected, and System Agent Maintenance doesn’t store password when you hit save. I needed to create a new app server to the same database with UsernameWindowsChannel binding to get the passwords corrected.

1 Like

Dear Rick,

I have checked and found same issue. I have tested on Epicor ERP and May be its bug.

1.First Set the application Net.Tcp Endpoint Binding with UsernameWindowsChannel and set the System Agent (System Setup>System Maintenance>System Agent )with print or manager account user who have all company rights.
2. After that, Set the application Net.Tcp Endpoint Binding with Windows from Epicor Admin Console
3. Submit the All Scheduled Tasks which is required.

Note:- Don’t remove the username and password from System Agent. Otherwise you will face same issue.



Hi there, we encountered this also when setting up/ refreshing our test systems using Windows as the binding, The alternative to changing the binding was to capture the password from the ice.Sysagent table prior, and then exectute an update statement after restore. Not ideal but does save time.

update Ice.SysAgent
Set syspassword = ‘##############’
Where Agentid= ‘System Task Agent’


I had a similar problem and this odd fix worked for me too.

@sanjeev.gupta Used this today on day one of 10.2.400.15



And thanks for paying this forward. Used it today in 10.2.600.15

I didn’t exactly do the same thing, but this inspired me.

I kept hitting a wall where the password in the System Agent would be blank even though I knew it was a valid password. What I mean is that I entered the password and saved and there was no error, but if I refreshed the screen (or closed and reopened), the password always disappeared. @ERPSysAdmin, you may appreciate that, based on another post I read here.

So what I did was to open Epicor in my non-SSO instance and entered the System Agent password there. It saved it and kept it, and I can print and do processes now - even in the SSO instance. Woohoo!

I would die without this forum.


this worked for me today in Kinetic 21.1.13

I had to setup a non-SSO for ours today just to set the PW. Don’t know what happened but the PW cleared all of a sudden and like you I’d of been lost without EpiUsers.help