Menu Security

I have an employee that has used the Data Fix Workbench in 10.0.700.4, I
copied the menu into job management general operations so I didn’t have to
open up security in Security Management.

Now in E10.1.500.18 epicor has tightened up security, so when we try to open
up Data Fix Workbench we get can’t open because not a Security Manager. the
user name is installed in the allowed users but it is being over-ridden by
the main menu.

Can anyone give me an idea on how to set up access to this menu?

Gary Wojtowicz

AJR Industries, Inc.

Is the user not seeing the data fix workbench on the menu at all


are they able to see it and click on it, but get an error when launching?

I don’t have that version. But is the Security Manager Only option still in Menu Security?

Check to see if that is on.

The user is able to see the data fix workbench

and launch it but when the user go to search for Data fix the error Business Layer exception displays,

This feature is only available to a Security Manager. Please contact your administrator.

yes it is still the same

I have been playing around with turning it off on the main menu then applying it on the sub menus

still no success

get this Business Logic Error,

This feature is only available to a Security Manager. Please contact your administrator.

If you’re seeing a business logic error like that, that means it’s coded that way/intentional and in order to get past it one has to give the error what it’s asking for–a user with the security manager right :confused: .

I don’t see a specific SCR that changed this after searching for a few minutes, but, when we rewrote the data fix import process to be from the EAC instead of the client (from 10.0 to 10.1) I suspect the change you’re running into was made to match the requirements of the conversion workbench as they both can bulk manipulate data.

There is an enhancement request on the books (185507 targeted to 10.2) requesting that we split out all of the individual privileges that the current security manager property grants a user to allow for better segregation of duties and having this split out is reasonable to me so I added a note in the SCR to include it.

I have moved from E10.0.400.7 to E10.1.500.18

Went to make a new BAQ report and ran into some new changes Epicor BAQ
Report Designer.

They removed the Design SSRS report link to build a new report with Download
SSRS Report and Upload SSRS Report

and as usual I haven’t been able to get much help from Epicor Support, they
send you KB0029266 article, which basically tells you that you now need to
download and upload.

They haven’t updated EpicorICETools_UserGuide_101500.pdf with the new info.

Does anyone have any info on how a new BAQ SSRS report is supposed to be
built in E10.1.500.18?

Gary Wojtowicz

AJR Industries, Inc.

We are on 10.2.600.6 and the DataFix Workbench still requires Security Manger status to be able to access it. Is there a way to find out if this has been changed in a later version?